Browse Source

Updated to latest build tools

Replaced scala plugin with fork at
https://github.com/xelnaga/gradle-android-scala-plugin

This fixes #56
drone-io
Felix Ableitner 5 years ago
parent
commit
f50d0697e6
  1. 3
      .gitmodules
  2. 24
      android/build.gradle
  3. 36
      android/proguard-rules.txt
  4. 2
      build.gradle
  5. 1
      buildSrc
  6. 4
      gradle/wrapper/gradle-wrapper.properties

3
.gitmodules

@ -0,0 +1,3 @@
[submodule "buildSrc"]
path = buildSrc
url = https://github.com/xelnaga/gradle-android-scala-plugin.git

24
android/build.gradle

@ -1,17 +1,8 @@
apply plugin: 'com.android.application'
apply plugin: 'jp.leafytree.android-scala'
buildscript {
repositories {
jcenter()
}
dependencies {
classpath "jp.leafytree.gradle:gradle-android-scala-plugin:1.4"
}
}
dependencies {
compile 'com.android.support:design:24.2.0'
compile 'com.android.support:design:24.2.1'
compile 'com.android.support:multidex:1.0.1'
compile 'org.scala-lang:scala-library:2.11.7'
compile 'com.mobsandgeeks:adapter-kit:0.5.3'
@ -34,12 +25,12 @@ preBuild.doFirst {
}
android {
compileSdkVersion 23
buildToolsVersion "22.0.1"
compileSdkVersion 24
buildToolsVersion "24.0.2"
defaultConfig {
applicationId "com.nutomic.ensichat"
targetSdkVersion 23
targetSdkVersion 24
versionCode 17
versionName "0.5.2"
multiDexEnabled true
@ -51,13 +42,6 @@ android {
applicationIdSuffix ".debug"
testCoverageEnabled true
}
release {
// HACK: This shouldn't be needed, but multidex isn't working correctly.
// https://code.google.com/p/android/issues/detail?id=206131
// https://code.google.com/p/android/issues/detail?id=209084
minifyEnabled true
proguardFiles getDefaultProguardFile('proguard-android.txt'), file('proguard-rules.txt')
}
}
// Increasing minSdkVersion reduces compilation time for MultiDex.

36
android/proguard-rules.txt

@ -1,36 +0,0 @@
# Add project specific ProGuard rules here.
# By default, the flags in this file are appended to flags specified
# in /home/sg/adt/sdk/tools/proguard/proguard-android.txt
# You can edit the include path and order by changing the ProGuard
# include property in project.properties.
#
# For more details, see
# http://developer.android.com/guide/developing/tools/proguard.html
# Add any project specific keep options here:
# If your project uses WebView with JS, uncomment the following
# and specify the fully qualified class name to the JavaScript interface
# class:
#-keepclassmembers class fqcn.of.javascript.interface.for.webview {
# public *;
#}
-dontobfuscate
-keep class scala.** { *; }
-keep class slick.** { *; }
-keep class org.joda.time.** { *; }
-keep class org.h2.** { *; }
-keep class java.util.** { *; }
-keepclassmembers class java.util.Comparator {
public *;
}
-dontwarn scala.**
-dontwarn slick.**
-dontwarn org.joda.time.**
-dontwarn org.h2.**
-dontwarn java.util.function.**
-ignorewarnings

2
build.gradle

@ -5,7 +5,7 @@ buildscript {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:1.3.1'
classpath 'com.android.tools.build:gradle:2.2.0'
classpath 'com.github.ben-manes:gradle-versions-plugin:0.13.0'
}
}

1
buildSrc

@ -0,0 +1 @@
Subproject commit fc9d3267aa2edf6442fea79084cce03ecd2bde34

4
gradle/wrapper/gradle-wrapper.properties

@ -3,5 +3,5 @@ distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.9-all.zip
distributionSha256Sum=4647967f8de78d6d6d8093cdac50f368f8c2b8038f41a5afe1c3bce4c69219a9
distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip
distributionSha256Sum=88a910cdf2e03ebbb5fe90f7ecf534fc9ac22e12112dc9a2fee810c598a76091